# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:[-_]?[0-9]+x[0-9]+)+"
test_str = ("http://url.com/0304-parapente-lagoon-Reunion-96x64.jpg\n"
"http://url.com/0304-parapente-lagoon-Reunion-960x640.jpg\n"
"http://url.com/0304-parapente-lagoon-Reunion-1500x1000.jpg\n"
"http://url.com/0304-parapente-lagoon-Reunion-1280x840-960x640.jpg\n"
"http://url.com/0304-parapente-lagoon-Reunion.jpg\n"
"http://url.com/520963918_960x540.jpg")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.