package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((http|https)(\:\/\/)((([a-zA-Z_\-0-9]{1,2000})(\.)([a-zA-Z_\-0-9]{1,2000})(\.)([a-zA-Z_\-0-9]{1,16}))|(([a-zA-Z_\-0-9]{1,2000})(\.)([a-zA-Z_\-0-9]{1,16})))((([\:\/a-zA-Z\ _\-%0-9\.\?\=]{1,3000})|(\/)|())))`)
var str = `http://127.0.0.1:80`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}