const regex = /(?:\b(abc|def|pqr|stu)\b.*){3,}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b(abc|def|pqr|stu)\\b.*){3,}', '')
const str = `abc def ghi jkl mno pqr stu`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}