$re = '/(?:[\[{,:\]}]+[\[{,:\]}\s]*"(*SKIP)(*FAIL)|"(?!\s*[\[{,:\]}]))/m';
$str = '{"Equipment Contents":["XL APPEARANCE GROUP","body-color grille","body-color body-side molding with chrome insert","luggage rack","15" deep-dish cast aluminum wheels","P235/75R15SL all-terrain OWL tires","power door locks","power windows","p
ower mirrors","cloth captains chairs"]}';
$subst = "\\$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;