#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^([+]|00|0$)(\d*)$"
Local $sString = "+" & @CRLF & _
"0" & @CRLF & _
"+123" & @CRLF & _
"00" & @CRLF & _
"0032476382763" & @CRLF & _
"+324763" & @CRLF & _
"" & @CRLF & _
"01" & @CRLF & _
"++" & @CRLF & _
"3434"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")