package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)^([+]|00|0$)(\d*)$`)
var str = `+
0
+123
00
0032476382763
+324763
01
++
3434`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}