use strict;
my $str = '
some text for test and need to replace by regex using php
we have extra sentence too';
my $regex = qr/(?<=regex\s)(.*)/msp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";