using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*TFG\/([^\/]+)\/([^\/]+)\/(.*)(\.py)";
string substitution = @"$1.$2.$3";
string input = @"/foo/bar/spam/regex/TFG/pacman/search/file.py";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}