$re = '/.*TFG\/([^\/]+)\/([^\/]+)\/(.*)(\.py)/';
$str = '/foo/bar/spam/regex/TFG/pacman/search/file.py';
$subst = "$1.$2.$3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;