import re
regex = re.compile(r"\[.*?\]")
test_str = (".\n"
"g\n"
"*\n"
"fisudfios\n"
"[sfsdfsdfsf]\n"
"[?]\n\n\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)