package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\S+?):{1,2}`)
var str = `*, ::before, ::after // do not capture anything
.class1, .class2:before,.class3::after // captures .class2 and .class3
.class4::before // captures .class4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}