re = /(\S+?):{1,2}/
str = '*, ::before, ::after // do not capture anything
.class1, .class2:before,.class3::after // captures .class2 and .class3
.class4::before // captures .class4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end