use strict;
my $str = '10, 20, 30, 40, 50, 60, 70, 80, 90, 100, 000.0110, 120, 130, 260, 330';
my $regex = qr/^\.$/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";