$re = '/!Automod(erator)?\S? approve this/m';
$str = '!Automod approve this
!Automod, approve this
!Automoderator approve this
!Automoderator, approve this';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);