using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href\=\""([^\""]*)\""";
string input = @"<hr />
<ul>
<li><strong>خالد المشيقح:</strong></li>
</ul>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/01.mp3"">شرح التسهيل 1 </a></p>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/02.mp3"">شرح التسهيل 2 </a></p>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/03.mp3"">شرح التسهيل 3</a></p>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/04.mp3"">شرح التسهيل 4</a></p>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/05.mp3"">شرح التسهيل 5 </a></p>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/06.mp3"">شرح التسهيل 6</a></p>
<ul>
<li><strong>عبدالسلام الشويعر:</strong></li>
</ul>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/07.mp3"">شرح التسهيل 7</a></p>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/08.mp3"">شرح التسهيل 8 </a></p>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/09.mp3"">شرح التسهيل 9 </a></p>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/10.mp3"">شرح التسهيل 10</a></p>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/11.mp3"">شرح التسهيل 11 </a></p>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/12.mp3"">شرح التسهيل 12 </a></p>
<ul>
<li><strong>سامي الصقير:</strong></li>
</ul>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/13.mp3"">شرح التسهيل 13 </a></p>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/14.mp3"">شرح التسهيل 14 </a></p>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/15.mp3"">شرح التسهيل 15</a></p>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/16.mp3"">شرح التسهيل 16</a></p>
<p><a class=""stealth download-pill"" href=""https://archive.org/download/Kitab_Tasheel_fi_Fiqh/17.mp3"">شرح التسهيل 17 </a></p>
<hr />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}