$re = '/f\(([\'"])(.*?)\1\)/i';
$str = '<?php
# Some code ....
$a = f(\'A\');
$b = F("B");
# more code ...
File 2:
<?php
# Some code ....
$c = F("ABC");
$d = f(\'1938\');
# more code ...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);