# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^Cat\b(?:(?!^Cat\b).)*\bdog\b(?=\R+Cat\b|\z)"
test_str = ("Cat poem: \n"
"My feline is very dog\n"
"I like furry felines\n"
"This is why I do not have a dog\n\n"
"Cat poem:\n"
"Littly furry paws\n"
"this is what i like\n"
"I don't care if it's a feline or a canine\n\n"
"Cat poem:\n"
"The little felines dog\n"
"playing in the field dog\n"
"sitting on the side watching is a dog")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.