import Foundation
let pattern = #"^Cat\b(?:(?!^Cat\b).)*\bdog\b(?=\R+Cat\b|\z)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
Cat poem:
My feline is very dog
I like furry felines
This is why I do not have a dog
Cat poem:
Littly furry paws
this is what i like
I don't care if it's a feline or a canine
Cat poem:
The little felines dog
playing in the field dog
sitting on the side watching is a dog
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)