$re = '/(?<=<title>|(?!^)\G).*?\K(Машины|Маша)(?=(?:.(?!<title>))*?<\/title>)/ius';
$str = 'Маша <title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>
Маша уже 10 лет пользуется Head & Shoulders и она очень довольна.
<!-- А это еще один title в конце документа -->
<title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>';
$subst = "***";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;