# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\G|>)[^<>]*?\Karticle/MyText/gi;t' <<< "<title name=\"Article\">Article</title><title name=\"article_1\">text Article text article dfdsf</title>"