import Foundation
let pattern = #"(\G|>)[^<>]*?\Karticle"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"<title name="Article">Article</title><title name="article_1">text Article text article dfdsf</title>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"MyText"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)