package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^`)
var str = `567* hELLO 565 ^this is >>>>> a special ads special sy3mbol || 999999* fgdg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}