const regex = new RegExp('[\\W\\S]{0,64}bit\\S?so[\\W\\S]{0,64}', 'gi')
const str = `api = new Bitso('AFJHFF', '42376tfddd662')
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}