package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[A-z]*([0-3][\d]{0,5})$`)
var str = `ADS300000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}