Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
SELECT\s(.+)\sFROM\s(((?!\sWHERE).)+)(\sWHERE\s(.+))?
/
g
Input 1
1
New
SELECT 1 FROM table_name AS b WHERE id=3
Substitution
FROM $2 WHERE $5 GET $1