package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bST(?:REET)?+\B`)
var str = `703 6TH STREET SOUTHTEXAS CITY TX 77590
1201 WEST FRONT STREETCHESTER PA 19013-3496
1201 WEST FRONT STCHESTER PA 19013-3496
`
var substitution = "$0 "
fmt.Println(re.ReplaceAllString(str, substitution))
}