# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(https|http)://(dsc\.gg|discord\.gg|discord\.io|dsc\.lol)/?[\S]+/?"
test_str = ("https://dsc.gg/typical-utility\n"
"https://dsc.gg/contentcafécontentcafé \n"
"https://discord.gg/AQW3Uzu \n"
"https://dsc.lol/the-imagining \n"
" \n"
"https://discord.gg/AQU3Uzu\n"
"https://discord.io/suppt4x\n"
"https://dsc.gg/c3media\n"
"https://dsc.gg/typical-support\n\n"
"https://dsc.gg/yungsmp\n\n"
"https://dsc.lol/the-imagining\n"
"https://www.ps3cfw.com/cool.php?item=30424465")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.