$re = '/(\d*)?\s*?([a-zA-Z]+)\s*(\d+)(?::(\d+))?(\s*-\s*(\d+)(?:\s*([a-z]+)\s*(\d+))?(?::(\d+))?)?/m';
$str = 'John 14:16
1John 14:16
1 John 14:16
john 14:16
1john 14:16
1 john 14:16
Jo 14:16
1Jo 14:16
1 Jo 14:16
jo 14:16
1jo 14:16
1 jo 14:16
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);