#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<? #([a-zA-Z0-9-]+).+?>"
Local $sString = "hola amigo #nombre1" & @CRLF & _
"<div>" & @CRLF & _
" <input # style="hola" #nombre-incidencia type="text"/>" & @CRLF & _
" <div *ngFor=" #nombre2 of list">{{nombre}}</div>" & @CRLF & _
"</div>" & @CRLF & _
"<input #nombre3 type="submit"/>" & @CRLF & _
"<div #nombre4>Este es tu #nombreno</div>" & @CRLF & _
"<span#nombre5>Tu nombre</span>" & @CRLF & _
"" & @CRLF & _
"<input #nombre6 type="submit"/>" & @CRLF & _
"<div #nombre7>Este es tu #nombrenooo</div>" & @CRLF & _
"<span#nombre8>Tu nombre</span>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")