package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<? #([a-zA-Z0-9-]+).+?>`)
var str = `hola amigo #nombre1
<div>
<input # style="hola" #nombre-incidencia type="text"/>
<div *ngFor=" #nombre2 of list">{{nombre}}</div>
</div>
<input #nombre3 type="submit"/>
<div #nombre4>Este es tu #nombreno</div>
<span#nombre5>Tu nombre</span>
<input #nombre6 type="submit"/>
<div #nombre7>Este es tu #nombrenooo</div>
<span#nombre8>Tu nombre</span>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}