use strict;
my $str = 'hola amigo #nombre1
<div>
<input # style="hola" #nombre-incidencia type="text"/>
<div *ngFor=" #nombre2 of list">{{nombre}}</div>
</div>
<input #nombre3 type="submit"/>
<div #nombre4>Este es tu #nombreno</div>
<span#nombre5>Tu nombre</span>
<input #nombre6 type="submit"/>
<div #nombre7>Este es tu #nombrenooo</div>
<span#nombre8>Tu nombre</span>
';
my $regex = qr/<? #([a-zA-Z0-9-]+).+?>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}