re = /<? #([a-zA-Z0-9-]+).+?>/
str = 'hola amigo #nombre1
<div>
<input # style="hola" #nombre-incidencia type="text"/>
<div *ngFor=" #nombre2 of list">{{nombre}}</div>
</div>
<input #nombre3 type="submit"/>
<div #nombre4>Este es tu #nombreno</div>
<span#nombre5>Tu nombre</span>
<input #nombre6 type="submit"/>
<div #nombre7>Este es tu #nombrenooo</div>
<span#nombre8>Tu nombre</span>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end