using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"exec \w+ (?:.*?'(?<quotedWord>\w+)')+";
string input = @"exec GetNextSequence 'abc', @brokerId out, 'fds'
insert into [ttt](id, code, description, startDate, endDate)
values (@bid, @code, @code, getdate(), '099999')
....";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}