package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`exec \w+ (?:.*?'(?<quotedWord>\w+)')+`)
var str = `exec GetNextSequence 'abc', @brokerId out, 'fds'
insert into [ttt](id, code, description, startDate, endDate)
values (@bid, @code, @code, getdate(), '099999')
....`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}