use strict;
my $str = 'http://www.blogcdn.com/slideshows/images/slides/218/885/9/S2188859/slug/l/765-1.jpg';
my $regex = qr/([-a-zA-Z0-9]+)(\.[0-9a-z]{2,5})$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}