$re = '/someword\s+(?:\S+\s+){1,3}otherword/i';
$str = 'someword aaa otherword
someword aaa bbb otherword
someword aaa bbb ccc otherword
someword aaa bbb ccc ddd otherword
someword aaa bbb ccc ddd otherword someword aaa otherword someword aaa bbb ccc otherword someword aaa bbb ccc ddd otherword someword aaa bbb otherword
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);