// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)<img[^>]*alt=['"].+['"]"#).unwrap();
let string = ".. <img src=\"alt.png\" class=\"absmiddle\" alt=\"\" /> ..
.. <img src=\"alt.png\" class=\"absmiddle\" /> alt=\"ok\" ..
.. <img src=\"alt.png\" class=\"absmiddle\" alt=\"its_ok\" /> ..
.. <img src=\"alt.png\" class=\"absmiddle\" alt> ..";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}