using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|(?=\b(?:[a-z]*[A-Z]){1})(\w)|(?!^)\G(\w)(?!\b))";
string substitution = @"\1 ";
string input = @"It's a simple SEnTeNCE with a FEW word.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}