Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^[+]?([0-9]*[\.\s\-\(\)]|[0-9]+){3,24}$
/
gmi
Input 1
1
New
011 (416) 457 7845 +1 (416) 457 7845 011416457111 Standard Telephone numbers +61 1 2345 6789 +61 01 2345 6789 (zero entered is not required but enterd by user anyway) 01 2345 6789 01-2345-6789 (01) 2345 6789 (01) 2345-6789 1234 5678 1234-5678 12345678 ^(\+[1-9][0-9]*(\([0-9]*\)|-[0-9]*-))?[0]?[1-9][0-9\- ]*$ ^(\+[1-9][0-9]*(\([0-9]*\)|-[0-9]*-))?[0]?[1-9][0-9\- ]*$ ^\+([0-9]( |-|\+)?)?(\(?[0-9]{3}\)?|[0-9]{3})( |-)?([0-9]{3}( |-)?[0-9]{4}|[a-zA-Z0-9]{7})$ ^((\\+[1-9]{1,4}[ \\-]*)|(\\([0-9]{2,3}\\)[ \\-]*)|([0-9]{2,4})[ \\-]*)*?[0-9]{3,4}?[ \\-]*[0-9]{3,4}?$