using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"c.{0,2}?m.{0,2}?";
string input = @"abcemtcmncefmf";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}