$re = '/c.{0,2}?m.{0,2}?/';
$str = 'abcemtcmncefmf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);