# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
<img\b(?=\s)(?=(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*?\ssrc=['"]([^"]*)['"]?)(?:[^>=]|='[^']*'|="[^"]*"|=[^'"\s]*)*"\s?\/?>
"""
test_str = ("<img onmouseover=' if ( 6 > 3 { funSwap(\" src=\"NotTheDroidYourLookingFor.jpg\", 6 > 3 ) } ; ' src=\"http://website/ThisIsTheDroidYourLookingFor.jpeg\" onload=\"img_onload(this);\" onerror=\"img_onerror(this);\" data-pid=\"jihgfedcba\" data-imagesize=\"ppew\" />\n"
"some text\n\n"
"<img src=\"http://website/someurl.jpeg\" onload=\"img_onload(this);\" />\n"
"more text\n"
"<img src=\"https://en.wikipedia.org/wiki/File:BH_LMC.png\"/>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.