import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\n[^\\n]*start[^\\n]*\\n((?:.(?!start))*?)\\n[^\\n]*end";
final String string = "11111111111\n"
+ "123start123\n"
+ "1111111111\n"
+ "4567start4567\n"
+ "****\n"
+ "****\n"
+ "****\n"
+ "789end789\n"
+ "1234end1234";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}