use strict;
my $str = '11111111111
123start123
1111111111
4567start4567
****
****
****
789end789
1234end1234';
my $regex = qr/(?s)\n[^\n]*start[^\n]*\n((?:.(?!start))*?)\n[^\n]*end/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}