re = /\\textbf{([^}]*)}/m
str = '\\textbf{1 + 1} \\begin{center} \\textbf{some text in here:} \\end{center} and \\textbf{2} etc'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result