re = /(?<=\W)(c\+\+|css|c|java)(?=[^\w\+])/m
str = 'My favorite programming language is c++++.
My favorite programming language is c.
I programme in c and c++ a lot and java too!
I detest css.
My favorite programming language is c++.
My favorite programming language is c.
My favorite programming language is c+++.
My favorite programming language is cs.
My favorite programming language is c. Hello world
My favorite programming language is c++ Hello world
I programme in c++ a lot!
My favorite programming language is c+.
My favorite programming language is cc.
My favorite programming language is c++!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end