$re = '/(?:\D*(\d+)){2}/';
$str = 'Red,12,Green,5,Blue,6';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);