use strict;
my $str = '{% hi %}
fsda
{% endhi %}
{% hi %}
fsda
{% endhi %}';
my $regex = qr/(?<={% hi %})\n*.*\n*(?:{% endhi %})*?/p;
my $subst = 'huahuahauhauhauhauhauhauahuauu';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";