$re = '/[\p{P} ]+/u';
$str = '@üsername
(@username)
@username:
@user — name';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;