$re = '/[^0-9]?9984?[^0-9]+/';
$str = ',,9984asdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);